This product requires Microsoft .Net Framework 4.5 – SharePoint 2013 Installation Error

When you run Microsoft SharePoint Foundation 2013 Setup or SharePoint Server 2013 Setup on a computer that has the Microsoft .NET Framework 4.6 or 4.6.1 installed, you receive the following error message:

Setup is unable to proceed due to the following error(s):

This product requires Microsoft .Net Framework 4.5.

Cause

This problem occurs because the SharePoint Setup program does not recognize the .NET Framework 4.6 or 4.6.1 as a supported version of the .NET Framework.

Workaround

To work around this problem, make sure that the .NET Framework 4.6 or 4.6.1 is not installed when you run SharePoint Setup.

If the Microsoft .NET Framework 4.6 or 4.6.1 is already installed, follow these steps:

  1. Uninstall the .NET Framework 4.6 or 4.6.1 by using Programs and Features or .NET Framework Cleanup Tool.

    3138436
    For more information, see the “Uninstalling the .NET Framework” section of the .NET Framework Deployment Guide.

  2. Restart the computer.
  3. Run the SharePoint 2013 Products Preparation Tool to install the .NET Framework 4.5.2.
  4. Run SharePoint Setup to install SharePoint.

After SharePoint is installed successfully, you can upgrade from the .NET Framework 4.5.2 to the .NET Framework 4.6.

Add Comment